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Introduction 

This guide was written for use with the CowTech Ciclop 3D Scanner, which began as a Kickstarter project 

in February 2016. The aim of this guide is to show you how to get the highest quality scans possible, and is 

based off our own experience with using the scanner. It covers the physical act of scanning an object 

utilizing your Ciclop and a free accompanying program called Horus, and assumes that you already have a 

scanner built and ready to go. For help with assembling your CowTech Ciclop 3D Scanner, please see our 

assembly guides on the CowTech website: http://www.cowtechengineering.com/downloads 

This guide is not comprehensive. Usually there is a significant amount of post-processing work to be done 

after a scan. Although we do offer some related tips, please refer to the links below for help with any kind 

of post-processing work (if for example you want to turn your raw scans into meshes usable with a 3D 

printer or other 3D software packages).  

We also highly recommend taking a look at the following resources if you need troubleshooting help not 

covered in this document. 

Post-processing and Scanning Guides: 

 CowTech website’s downloads section - http://www.cowtechengineering.com/downloads 

 BQ’s Ciclop and Horus Documentation Page - http://diwo.bq.com/en/documentation-ciclop-and-

horus-2/  

 Horus Github - https://github.com/bqlabs/horus  

Troubleshooting Hardware and Electronics Related Issues: 

 CowTech Ciclop Facebook Group - https://www.facebook.com/groups/564912093672675/ 

 CowTech Ciclop 3D Scanner Google Group – 

https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-

3d-scanner 

Troubleshooting Software Related Issues 

 BQ Ciclop 3D Scanner Google Group - https://groups.google.com/forum/#!forum/ciclop-3d-

scanner  

 Horus Github - https://github.com/bqlabs/horus  

  

http://www.cowtechengineering.com/downloads
http://www.cowtechengineering.com/downloads
http://diwo.bq.com/en/documentation-ciclop-and-horus-2/
http://diwo.bq.com/en/documentation-ciclop-and-horus-2/
https://github.com/bqlabs/horus
https://www.facebook.com/groups/564912093672675/
https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-3d-scanner
https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-3d-scanner
https://groups.google.com/forum/#!forum/ciclop-3d-scanner
https://groups.google.com/forum/#!forum/ciclop-3d-scanner
https://github.com/bqlabs/horus
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Things to Have Before Starting 

There are a number of items you will want to have on hand before you begin scanning. If your kit has any 

damaged or missing parts, we are happy to send you replacements. Please email us at 

info@cowtechengineering.com.  

Assembling the Hardware 

You will need a fully assembled Ciclop. If you haven’t done so yet, please refer to the “downloads” section 

of the CowTech website for assembly instructions: 

http://www.cowtechengineering.com/downloads 

It is important to build the scanner in the order prescribed by the assembly instructions. Some parts in the 

assembly are press fit and cannot be taken apart again without risking damage. It pays to get it right the 

first time. 

The Calibration Pattern 

The calibration pattern is a grid of black and white 

squares that the camera uses to orient itself in 3D 

space. It is a critical piece of the scanner. You will need 

to use it to calibrate the scanner before every 

scanning session. A picture of a calibration pattern can 

be seen at right. It consists of two pattern holders 

(“feet”), a clear plate, and a sticker. 

To assemble the calibration pattern, simply press the 

feet into the slots of the clear plate. Then place the 

sticker centered on the clear plate. It is critical that the 

rows of boxes on the sticker are as parallel as possible 

to the edges of the clear plate. Try to be as careful as 

possible about parallelism when placing the calibration 

pattern. It is fine if the sticker is not perfectly centered 

as in the example at right. 

The stickers must also be oriented correctly. See the 

pictures at right. You want to ensure that the left hand 

corners have black squares and the right hand corners 

have white squares.  

Your scanning kit should come with two stickers in 

case you make a mistake with the first one.  

The calibration pattern is used only when calibrating. 

Never leave the calibration pattern on the table when 

scanning an object, as the scanner will include the 

calibration pattern in the scan. 

INCORRECT: White squares are in the 

left corners and black squares are in the 

right corners 

CORRECT: Black squares are in the left 

corners and white squares are in the 

right corners 

FEET 

CLEAR PLATE STICKER BLACK SQUARES 

mailto:info@cowtechengineering.com
http://www.cowtechengineering.com/downloads
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Assembling the Electronics 

The following sections will walk you through the process of 

putting the electronic components of the scanner together. This 

section is here so that you do not break any of your scanner’s 

parts. Please follow it carefully. 

Calibrating the Stepper Motor Driver (the Easy Way) 

At right is a picture of the Stepper Motor Driver. This component 

of the scanner should be handled with care. It can be shorted out 

and ruined with improper handling. Please carefully follow the 

instructions in this document to ensure that it works properly. 

The screw shown in the picture at right controls how much electrical current is given to the Ciclop’s stepper 

motor. This motor spins the scanning table, which allows the scanner to get a 360° view of an object. You 

want to ensure that this screw is adjusted to the right position. Too much electrical current, and the 

motor may eventually fail or the Stepper Motor Driver may overheat. Too little electrical current, and the 

motor will not turn properly and results in inaccurate scans. 

Orient the Stepper Motor Driver such that the screw is on the 

bottom and the black square is above it. See the section below 

titled “Plugging in the Boards and Components” for a picture of 

this orientation. The screw has a flat side. The flat side of the 

screw is normally pointing straight down. Using a Phillip’s head 

screwdriver, turn the screw 45° counterclockwise. This 

corresponds to the hour hand’s position on a clock at 4:30. See 

the diagram at right. 

If your Stepper Motor Driver is having issues, we highly 

recommend consulting the more detailed calibration guide 

presented at the end of this document. 

Stacking the Boards 

WARNING: It is easy to short out and ruin the Stepper Motor Driver on your scanner. Please ensure that 

none of the boards are plugged in while you connect them to one another. If any of the boards are 

powered while doing so, you run the risk of ruining the Stepper Motor Driver. 

The three circuit boards included with the Ciclop are shown below. 

SCREW 

HEAT SINK 
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Uno Clone CT Board Stepper Motor Driver 
 

The boards all stack on top of one another. The Uno Clone sits at the bottom of the stack, the CT board is 

in the middle, and the Stepper Motor Driver is on top. It is essential to properly orient the boards.  

 The CowTech logo on the CT Board should be oriented opposite from the USB and power plugs 

on the Uno Clone. 

 The small screw on the Stepper Motor Driver should be oriented closer to the power plug on the 

CT Board. On the CT Board, there is also a silkscreen just under the pins for the Stepper Motor 

Driver that indicates the proper orientation. 

A picture of all three boards correctly assembled can be found on the next page. 
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Plugging in the Boards and Components 

Make sure to plug in the boards and components as shown in the picture below. It is possible to damage 

the Stepper Motor Driver if the boards are plugged in incorrectly. The blue connections on the right side 

of the board will require a flathead screwdriver to secure in place. 

USB Plug to 

Computer 

DO NOT USE THIS 

PLUG 

Barrel Plug to 

Wall Outlet 

LED Strip. 

 Darker Wire on Top 

Lighter Wire on Bottom 

Darker Wire 

Lighter Wire 

Lasers. 

Black Wires in the Middle 

Red Wires connect as 

labeled on the silkscreen. 

Left and right are 

determined from the point 

of view of the camera, which 

faces toward the scanning 

table. 

Stepper Motor. 

Make sure the blue wire is 

to the left. 

The wire on the right may 

or may not be black. It’s 

fine if the wire is not black 

as labeled. 

 

 

 

Heat Sink. 

The heat sink has an adhesive backing. Peel 

off its cover and stick it to the black square 

on the middle of the Stepper Motor Driver. 
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Installing the Software 

Horus 

Horus is a software program on your computer that connects to the Ciclop scanner. This guide was 

written for use with Horus version 0.2rc1. You can download Windows, Mac, or Ubuntu versions of Horus 

for free at the link below. Run the installer and follow the onscreen instructions. The installer may give 

you the option to install “FTDI Drivers” or “Arduino Drivers.” Neither are necessary to run the CowTech 

Ciclop 3D Scanner.  

https://github.com/bqlabs/horus 

After installation, it is recommended that you restart your computer before continuing. 

Uno Clone Drivers 

Horus interfaces with the components of the scanner via 

the Uno Clone. In order to enable your computer to 

recognize the Uno Clone when it’s plugged in, you may 

have to download and install Uno Clone drivers. These 

drivers can be found on the CowTech website. Please see 

the link below. Unzip the file, run “SETUP.EXE,” and then 

click “INSTALL.”  

http://www.cowtechengineering.com/downloads 

Logitech C270 Webcam Drivers 

The Ciclop uses a Logitech C270 Webcam to make scans. 

Although your computer may recognize the webcam if 

plugged in straight out of the box, Horus will not be able 

to. Horus requires a special set of webcam drivers, all of 

which can be obtained from the Logitech website below. 

Make sure that you download drivers that match your 

operating system. The installer will give you the option to 

install: 

 “Logitech Webcam Drivers” 

 “Logitech Webcam Software” 

 “Logitech Motion Detection” 

The last two options are not necessary to run the CowTech Ciclop 3D Scanner. 

http://support.logitech.com/en_us/product/hd-webcam-c270 

If you ever have trouble getting Horus to recognize the webcam, uninstall and then reinstall Horus. In some 

cases, Horus needs to be able to see the Logitech C270 drivers during installation in order to recognize 

https://github.com/bqlabs/horus
http://www.cowtechengineering.com/downloads
http://support.logitech.com/en_us/product/hd-webcam-c270
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them properly. If your problem persists, see our troubleshooting guide at the end of this document for 

more help. 

How the 3D Scanner Works 

The CowTech Ciclop can generate scans with or without a texture. A scan with texture will be colored like 

the object is, while a scan without texture will be the object’s geometry only. The Ciclop utilizes a camera, 

two lasers, and a spinning table to make scans. 

When an object is placed on the spinning table, the lasers flash on and “paint” the object with vertical red 

lines. The camera takes an image and records the areas that show up as red on the object. If the scan is 

recording textures, the camera also records the colors visible at these areas. This happens just after the 

lasers flash off. The table then rotates at a very small angle (usually a fraction of a degree) and the 

process repeats until the table makes a full revolution.  

The output of the scan is known as a “point cloud” and is saved as a .ply file. A point cloud is simply a 

collection of coordinates that represent points in 3D space. Calibrating the scanner ensures that Horus 

knows how much the table spins and the locations of the camera / lasers with respect to the object. It 

uses this information to coherently assemble these points in 3D space so that they resemble the scanned 

object. Smaller angles of rotation will take longer but result in higher resolution scans. 

The quality of your scans will vary widely based on three important factors: 

 Object – colors, finish, and features of the scanned object 

 Lighting – ambient lighting in the room 

 Calibration – brightness, contrast, saturation, and exposure of the camera 

The remainder of this guide will walk you through our process for generating scans step by step.  
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Selecting an Object 
Select an object suitable for scanning. The Ciclop uses red lasers to highlight sections of an object for the 

camera to record in 3D space. When selecting an object to 3D scan, it’s important that the object makes 

it easy for the camera to see the red lasers. It’s ultimately up to you to experiment with what works and 

what doesn’t, but the following are good guidelines to follow for your first scan. 

Shiny or reflective objects are difficult to scan. They reflect the lasers off their surface, making the object 

more difficult for the camera to detect. Additionally, a reflective surface will reflect different areas of its 

surroundings while it rotates around, meaning that the camera will not be able to capture its textures 

well. 

Red, black, or darkly colored objects are difficult to scan. Red surfaces are difficult to tell apart from the 

red light from the lasers. Black surfaces tend to absorb of the laser’s light, making it difficult for the 

camera to detect the object. Other colors like dark brown and dark purple 

are likewise hard to detect. If the object you would like to scan is red, 

black, or darkly colored in certain areas, it is likely that it will show up as 

blank spaces in the scan and require significant post-processing work to 

fix. 

Concave or interior features are difficult to scan. Concave features are 

areas of an object that form pockets or overhangs. The lasers generally 

can’t reach the inside of the pockets, and they’ll show up as large holes in 

the model. Models with rounded, convex features generally result in 

better scans. 

Significant detail on the top of bottom of an object may require multiple scans and post-processing work to 

properly capture. The lasers generally don’t see the top or base of an object. If you’d like to capture these 

areas of an object, please see our supplementary post-processing tips at the end of this document. 

  

CONCAVE

 

CONVEX
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Calibration 

Calibration is the difference between a good scan and a bad scan. Follow all of the steps below to ensure 

that you get a good one. If you come across any further tips and tricks, please do share them with us on 

our FaceBook page! https://www.facebook.com/groups/564912093672675/ 

When you first start up Horus, you’ll be greeted by the window shown below. Close the window. The 

window prompts you to launch the “wizard,” and in our experience the wizard generally does not make 

for very good calibrations. You can get much more accurate scans by calibrating manually. 

 

Horus’ functionality is divided into four separate windows called “Workbenches.” Each workbench is suited 

to a different step in the calibration process. You can cycle through the workbenches by clicking on the 

drop-down bar on the top right corner of the window. The default workbench is the Scanning 

Workbench, which is what you see below. You can stay on the Scanning Workbench for now. 

 

SWITCHES BETWEEN 

WORKBENCHES 

https://www.facebook.com/groups/564912093672675/
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Connecting the Camera 

1 
 
Ensure that there is power to the scanner. Plug in the camera and the Uno Clone to your computer. 
 

2 

 
Go to Edit -> Preferences and ensure that your 
settings match those shown at right. Also make 
sure that your baud rate is set to 115200.  
 

 
3 

 
Press “Upload Firmware”. If you are having issues 
uploading firmware, try changing the “COM” port 
selected under “Serial Name”. It may also help to 
restart Horus after changing any settings. If this 
does not help, please see our troubleshooting 
tips at the end of this document. 
 

4 

 
Press the Connect Icon on the top left corner of 
the screen.  
 
Failure to connect seems to be the most common 
issue the scanners have with Horus. Please see 
our troubleshooting tips at the end of this 
document if nothing seems to work, and please 
don’t hesitate to consult the CT Google Group if 
your issue is not covered in this guide. 
Remember: the CowTech team is here to help! 
 
If all goes well, you will see live footage from the 
camera in the middle segment of the Scanning 
Workbench. 
 

 

 

  

CONNECT ICON 
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Using the Control Workbench 

The Control Workbench helps you test the different components of the scanner. You can use it to 

troubleshoot any issues you may have with the motors, lasers, or camera. The button on the left side of 

the workbench can control all of these components. 

We’ll use the Control Workbench to make sure that our lasers and object are in a good position to scan. 

Vertically Align the Lasers 

1 

Place the calibration pattern on the table. 
The calibration pattern comes with your 
scanner, and it’s fairly important. Don’t 
lose it! Be sure that it is as perfectly 
perpendicular with the table as possible. 
If the calibration pattern is skewed, you 
may get some skewed scans after 
calibration. 

 

2 

Turn on the left and right lasers. Use the 
buttons on the left side of the Scanning 
Workbench. In the picture at right, you 
can see that the left laser is much broader 
(and therefore dimmer) than the right 
laser. This needs to be fixed. 
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3 

 
Focus the lasers. The lasers have a small 
plastic lens on the end that focuses the 
beam into a line. Rotate it to make the 
line as thin and bright as possible. A thin 
laser makes it easier to capture fine 
detail. 
 
If you are having trouble with this step, 
please see the more detailed Laser 
Focusing Guide in the Supplemental 
Troubleshooting Guides section at the 
end of this document. 

 

4 

Rotate the lasers so that they’re vertical. 
You can use the borders between the 
checkers to help align the lasers. They 
should be perfectly parallel. 

 
 

Ensure Good Laser Coverage 

1 

Remove the calibration pattern and place 
your object on the table. The calibration 
process will require a lot of switching back 
and forth between the two, so keep the 
calibration pattern handy. 

 

FOCUSING LENS 
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2 
Rotate the table with your hands. You may 
notice that the lasers don’t hit as much of 
the object at certain angles.  

 

3 

Adjust the position of the lasers or object 
to ensure good coverage. Good coverage 
means that the lasers are visible along the 
entire length of the object. Ensure that 
this is true for all angles of the table. It 
may take some guess and check work to 
get it right. Some examples of good and 
bad coverage are given at right. 

GOOD 

 

 
 

 

BAD 

   

4 

 
Mark object’s position on the table. You will want to be able to replicate the objects current 
position later. A piece of tape works well to mark the boundaries of the base of the object. If you 
adjusted the position of the laser holders, it may also be worth it to make sure the lasers are still 
vertical and focused, as it’s easy to accidentally skew them during this step. 
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A Quick Detour to the Calibration Workbench 

Before you begin using the Adjustment Workbench in the next section, it is helpful to quickly check some 

settings in the Calibration Workbench. Follow the steps below to ensure that your calibrations will work 

properly. 

1 

 
Go to Calibration Workbench -> Pattern 
Settings. Make sure that rows and columns 
are set at 6 and 11, respectively. If you look 
at the grid on the calibration pattern, you 
might notice that there are in actually 7 
rows and 12 columns. Regardless, if you 
set these values to 7 and 12, your scanner 
will not be able to recognize the patterns. 
BQ (the makers of Horus) may change this 
at some point in future versions. 
 
Also set the square width to 12.7 mm. 
You’re free to measure this yourself, but 
this value has worked well for us and 
should be consistent across all CT Ciclop 
scanners. The more accurate you can get 
this value, the better your calibration will 
be. Better calibrations mean better scans! 
 

 

2 

Measure origin distance as accurately as 
possible. The origin distance is measured 
from the bottom edge of the feet of the 
calibration pattern to the top edge of the 
nearest square. We recommend using 
calipers if you have them. The more 
accurate you can get this value, the better 
your calibration will be. Better calibrations 
mean better scans! Input this measured 
distance into the appropriate field. 

 
 

  

ORIGIN DISTANCE 
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Using the Adjustment Workbench 

The adjustment workbench is where you adjust the camera’s settings. The camera’s settings are crucial. 

When using the lasers, the camera relies on distinguishing red from other colors to differentiate the 

object’s space from empty space. When calibrating, the camera relies on distinguishing white from black 

to detect the calibration pattern. The Adjustment Workbench lets you adjust the camera’s settings 

separately for each task to maximize its ability to tell colors apart.  

Success is dependent on the lighting of the room. Although we have some general tips about lighting, you 

may need to experiment with different kinds of light to get good results. 

Calibration Capture 

Calibration Capture covers all the settings that govern how the camera looks at the checker pattern during 

calibration. Horus tells you if the camera can detect the pattern by displaying a series of rainbow lines 

running between the squares on the camera’s feed at the right side of the workbench.  

The trick is to get Horus to display these rainbow lines for as wide a range of rotation as possible. Rotating 

the table away from the position where it directly faces the camera makes the pattern slanted from the 

camera’s perspective. The more slanted the pattern can be while still displaying the rainbow lines, the 

better the calibration will be. 

1 Place the calibration pattern on the table. 

 

2 

Adjust the light until you see the rainbow 
lines. The picture at right gives you an 
example of what the rainbow lines look 
like. Horus can get quite picky about 
recognizing the pattern, so be prepared to 
adjust the settings of the camera and 
experiment with a few different light 
sources. 

 

RAINBOW LINES 
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- 

The more indirect the light is, the better. 
Direct light can cause glare on the slightly 
reflective surface of the sticker, which 
makes the black squares in some areas 
indistinguishable from the white ones. The 
picture at right is an example of this. If 
even one square is obscured by too much 
glare, Horus will not recognize the pattern.  
 
To get more indirect light, try shining a 
lamp at a white surface near the scanner. 
The white surface will bounce a fair 
amount of indirect light onto the pattern 
without glare.  

3 

Rotate table to the left or right with your 
hand. Try to see how far you can rotate 
the table before the rainbow lines go 
away. They usually go away when one side 
of the pattern is exposed to less light and 
becomes darker. When the pattern’s 
lighting becomes inconsistent like this, 
Horus will fail to recognize the pattern. 
The picture at right shows the angle at 
which Horus just begins to stop 
recognizing the pattern 

 

4 

Add light sources to either side of the table.  
This increases the scanner’s range of 
pattern detection. At right you can see 
how this allows Horus to detect the 
pattern at a steeper angle of rotation. 
Again, this may take some time to get 
right. 

 

TOO BRIGHT (GLARE) 

TOO DARK 
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4 

Fiddle with settings to get Horus to detect 
the pattern at as steep angle as possible. 
The picture at right is the result of 
modifying only the brightness, and gives a 
decent angle of detection. Generally, you 
want to be able to detect the pattern 
when displaced at least 45° from its initial 
position directly facing the camera. If you 
can do more, do it! 

 

- 

Be patient and experiment. After adding 
more light and adjusting all the settings, 
we arrive at an angle that’s roughly 65° 
from the initial table position. It may take a 
little patience and guess and check work to 
get it right. 

 

6 

Maximize the range for the other side as 
well. The picture at right is the result of 
adding some indirect light to the right side 
of the table. 

 

7 

 
Check the pattern when facing the camera directly once again. Slowly rotate the table with your 
hand all across the range where the pattern is detected. Sometimes adding more light on the sides 
will make the pattern too bright in the center, giving detection on the sides but not in the middle. 
Make sure that the rainbow lines are detected along the entire range of rotation from left to right. 
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Calibration Segmentation 

Calibration segmentation covers all the settings that govern how Horus tells red laser light from other 

colors. Horus will show you which areas register as laser light with white highlights, while leaving 

everything else black. This is important during calibration, when Horus uses light from the lasers shining 

on the calibration pattern to orient the lasers and table in relation to the camera. 

The goal is to get Horus to detect only the laser light that shines on the white squares. Ideally, the areas 

where the laser lines hit the black squares should not be detected. We also want to lines to be stable (not 

constantly shifting) and to be relatively crisp. 

1 

Turn off the lights. For this step, less 
ambient light will allow the red laser light 
to shine brighter and make it easier to 
detect. The lights will stay off when it’s 
actually time to scan. We can do this 
because we are not capturing a texture. 
 
If we were capturing a texture, we would 
want to keep the lights on during 
scanning. Lights on means that you get an 
accurate depiction of the object’s colors. 
Just be warned that texture scans may 
make calibration more difficult and 
possibly compromise the level of detail of 
the scan. 

 

2 

Make sure Horus does not detect the 
background. In the picture on the 
previous step, the top four lines are from 
the wall rather than from the calibration 
pattern. To remove them, hang a darkly 
colored sheet behind the table or move 
the table further away from the wall. 

 

AREA ABOVE 

PATTERN IS NOT 

DETECTED 
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3 

Fiddle with the settings until only white 
squares are detected. It can be difficult to 
make it so that all of them show up with 
equal thickness. It’s fine if only two or 
three of the white squares show up on 
each laser. Experiment with the settings 
to see what works best. A brief 
description of each one is below. 

 
 Threshold – Changes the minimum intensity of light that counts as laser light. Any pixel that 

falls below this value is discarded. This is like the “brightness” setting on the camera. 
 Blur – Draws a box around each pixel. That pixel’s intensity will count only as the average of all 

pixels within the box. The value of Blur changes the size of the box drawn. This is similar to the 
“saturation” or “contrast” setting on the camera. 

 Window – Discards pixels that fall outside a certain distance from the highest intensity pixels in 
the image. This is similar to the “exposure” setting on the camera. 
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Scan Segmentation 

1 

Put your object on the table. This step is 
just like Calibration Segmentation, except 
you use the object rather than the 
calibration pattern. 

 

2 

Fiddle with the settings. Depending on 
the color of your object, they might be 
slightly different from those from 
Calibration Segmentation. Examples of 
some bad settings are at right. Use the 
picture above these three as an example 
of good segmentation. 

 
 

 

 
 

 

 
 

 
TOO CHOPPY TOO THIN TOO BLURRY 

 

3 Rotate table to ensure good coverage. Double check that the lasers hit all the areas of your object 
that you want to scan. 
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Saving the Adjustment Profile 

The settings you got from the previous steps can be saved and loaded for later. This is 

extremely useful as long as you have consistent lighting, as it saves you the trouble of 

fiddling with settings each time you’d like to scan. The files are saved with the .json file 

extension. 

Using the Calibration Workbench 

The calibration workbench is how the scanner figures out where its components are in 

3D space. This is crucial for making the model geometrically accurate. Once the camera 

settings have been worked out in the Adjustment Workbench, the scanner accounts for 

distortions caused by the camera’s lens and triangulates the positions of the lasers, and 

table. 

Pattern Settings 

Ideally, you have already set the correct Pattern Settings earlier in this guide. Please see the section titled 

“A Quick Detour to the Calibration Workbench” page 14 for a walkthrough on what to do. 

Scanner Autocheck 

Skip this calibration. Scanner Autocheck simply turns on all of the components of the laser and confirms 

that they work. We recommend against using this, as occasionally it will cause the stepper motor to 

behave erratically. Regardless, by now it should be fairly obvious if something doesn’t work on the 

scanner. 

Camera Intrinsics 

1 

Go to View -> Advanced Mode. Make 
sure that Advanced Mode is enabled 
with a check mark. This is the only way 
that you will be able to access the 
Camera Intrinsics settings. 

 

2 

This step accounts for distortion in the 
camera’s lens. It works by taking many 
pictures of the calibration pattern in as 
wide a range of positions as possible.  
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3 

Use your hand the move the calibration 
pattern around as directed. Aim for as 
wide a range of positions and angles as 
the scanner will detect. You will know if 
the scanner is detecting the pattern via 
the rainbow lines. Press spacebar for 
each new position. Horus will take a 
snapshot of each one. 

 

4 

Click accept if the results seem 
reasonable. Each colored plane in the 
diagram represents a one of the nine 
orientations of the calibration pattern. 

 
 

Laser Triangulation 

1 

Run the Laser Triangulation calibration. 
Make sure you have the pattern on the 
table when you do. The result should look 
similar to what is shown at right. The two 
numbers floating next to the red planes 
should be somewhere between 0.05 and 
0.06. 
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- 

If those numbers are off, the scanner isn’t 
properly detecting the laser. Readjust your 
settings for Calibration Segmentation and 
try again. You can see an example of a bad 
triangulation on the right. 

 
 

Platform Extrinsics 

1 

Run the Platform Extrinsics calibration. If 
Laser Triangulation worked without a 
problem, this should work fine as well. It 
will spin the table and record a number of 
frames at different angles.  

 

- 

Make sure that your result is similar to the 
one at right. There should be many dark 
dots along the top right quarter of the 
circle inside the 3D graph. If there are 
fewer than shown at right, readjust your 
Calibration Capture settings and try again. 
You want to see as many as possible. 

 

Saving the Calibration Profile 

The calibrations you got from the previous steps can be saved and loaded for later. Just 

like adjustment profiles, these files are saved with the .json file extension. Please note 

that unlike adjustment profiles, we don’t recommend reusing calibration profiles 

between scanning sessions. Even the slightest bump of the table can set the lasers or 

table slightly out of alignment and compromise scan quality. Adjustment profiles can 

be reliably reused as long as your lighting setup remains the same. 

  

BAD VALUE 
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Using the Scanning Workbench 

Congratulations, you are now almost ready to scan! The Scanning Workbench is where you specify 

whether or not to capture texture, determine the Range Of Interest (ROI), and set the display color of the 

points captured. The rightmost pane of the Scanning Workbench will display the 3D model as it is 

captured. 

1 
Put your object on the table. Make sure 
it’s in the position you found earlier that 
provides good laser coverage. 

 

2 
Turn the lights off if you’re not capturing 
texture. If you are capturing texture, skip 
this step. 

3 

Set your ROI to the minimum area that will 
encompass your object. The ROI ensures 
that the scanner will not pick up 
erroneous points that are far from your 
model but still within the camera’s view. 

4 Press the play button on the top left 
corner. The scan will now begin! 

 

- 

The scan may take 10 to 20 minutes to 
complete. It may be hard to make out the 
details of your object at the moment, as 
the point cloud does not provide outlines 
for the object’s features. 
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5 
Save your model once the scan is 
complete. You are now ready to begin 
post-processing your model. 

 
 

After post-processing, your 3D model is ready to print! 
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Post-Processing Tips 

For help with post-processing your point cloud, please refer to the BQ guide on the page linked to below. 

http://diwo.bq.com/en/documentation-ciclop-and-horus-2/ 

Although the bulk of the information that you need for post-processing can be found at the link above, 

we have a few supplemental tips included below. Note that the BQ guide gives you the option of using 

either MeshLab or CloudCompare to process your point clouds. Our tips are only applicable when using 

MeshLab, although you could likely find analogous operations in CloudCompare. 

Don’t forget to post pictures of your cool scans on our FaceBook page! Likewise, if you’re stuck with an 

issue, we encourage you to reach out to the community for help on the CowTech Ciclop Google Group. 

 CowTech Ciclop Facebook Group - https://www.facebook.com/groups/564912093672675/ 

 CowTech Ciclop 3D Scanner Google Group - 

https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-

3d-scanner  

Inverting Normals Before Generating A Mesh 

Before you can make a mesh from the point cloud, you must generate normals for the model. Ideally, the 

normals poke outward away from the model so that it looks fuzzy. But sometimes the normals are facing 

inward. This can cause lots of problems when it comes time to build a mesh. MeshLab offers tool to invert 

the normals associated with a mesh already, but it does not offer any tool to do so if the mesh hasn’t 

been built yet. The following workaround allows you to invert the normals without a mesh. 

1 Open up your point cloud. At right you can 
see the object we scanned earlier. 

 

http://diwo.bq.com/en/documentation-ciclop-and-horus-2/
https://www.facebook.com/groups/564912093672675/
https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-3d-scanner
https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-3d-scanner
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2 

Display the normals. To do this, go to 
Render -> Show Normal/Curvature. (If you 
haven’t yet generated the normals, 
please read the BQ guide linked to earlier 
in this document!) 

 

3 

At right is an example of a bad set of 
normals. Generally it is easy to tell if the 
normals are bad because the normals 
look like scraggly hairs instead of a rich 
coat of fur. 

 

4 Go to Filters -> Normals, Curvatures and 
Orientation -> Transform: Scale.  
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5 

Set X, Y, and Z to -1.  
 
Set the “Center of Scaling” to 
“barycenter.” Press the “Apply” button.  
 
This will flip your model upside down, but 
it’s simple enough to reorient by clicking 
and dragging the left mouse button. 

 

6 
Recompute the normals and render them. 
The result should be much better! You 
are now ready to compute the mesh 
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Exporting A Mesh With Texture in .OBJ Format 

The following section assumes that you’ve already made your mesh and would now like to apply a texture 

to it. After adding the texture to it, it can be saved in the .obj file format. Normally, the .stl file format is 

used for 3D printing. Keep this in mind before beginning the following guide. Please ensure that the .obj 

file format is suited to your application. 

1 

Open up your mesh. Shown at right is a 
partially complete scan of a baseball. 
Ideally, this scan would be fused with 
another to cap off the top and bottom, 
but we will proceed with this scan alone 
for demonstration purposes. 

 

2 

Press Ctrl + L to see all of the layers 
present in your project. “Baseball_1.ply” 
is the point cloud currently visible, and 
“Processed_baseball_1.obj” is the mesh 
generated from it. 
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3 

Rename both layers such that there are 
no spaces in them. MeshLab does not 
like spaces in file names. Don’t forget 
this step, it will save you the hassle of 
redoing this entire process! 

 

4 

Select the mesh so that it’s highlighted 
yellow and click the small eye icons next 
to each layer’s name to toggle visibility. 
At right is the untextured mesh. 

 

5 

Go to Filters -> Texture -> 
Parametrization: Trivial Per-Triangle. This 
chops the point cloud colors into 
triangular bits that correspond to your 
mesh’s triangles. 
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6 

Change the “Texture Dimension (px)” 
field to 4096 and the “Inter-Triangle 
Border” field to 0. Do not check the 
preview box, this will often crash 
MeshLab. Hit “Apply” and then close the 
window. 
 
 

 

7 

Go to File -> Save Project. The steps after 
this may be destructive and reloading 
the file will be your way to revert back to 
square one. Again, make sure that there 
are no spaces in the name. 

 

8 

Go to Filters -> Texture -> Transfer Vertex 
Attributes to Texture (between 2 
meshes). This transfers your texture data 
onto the mesh. 
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9 

Change “Source Mesh” to be the name of 
your object’s point cloud. Leave “Target 
Mesh” the way it is. 
 
Change both “Texture Width” and 
“Texture Height” to 4096. 
 
Check the boxes titled “Assign Texture” 
and “Fill Texture.” Leave the “Overwrite 
Target Mesh Texture” box unchecked. 

 

10 

Click apply. It may take a while for 
MeshLab to generate the result. Close 
the parameter input window when 
MeshLab has completed the operation. 

 

11 

Open up the directory that your project is 
saved in. You should now see a .png file 
saved in the same directory as the .mlp 
file you saved earlier. 
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12 

Go to File -> Export Mesh As. Save the 
file as an .obj file and name it however 
you please. Make sure that there are no 
spaces in the name! MeshLab does not 
like spaces in file names. 

 

13 

Make sure that the “Vert – Normal” box 
is unchecked and “Wedge – TexCoord” is 
checked. The picture at right has a 
problem – there are spaces in the name! 
Make sure you don’t make that mistake. 

 

14 

Go back to the directory where you have 
saved all your files. You now have three 
files of three different types: .obj, .mtl, 
and .png. They should all be in the same 
directory like they are at right. If they 
are not, move them so that they are. 
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15 

Open up the .obj file in Notepad or 
another text editor of choice. Notice that 
it references the .mtl file. The line that 
does this is highlighted in the picture at 
right. 

 

16 
Open up to .mtl file in Notepad as well. 
We see that this file in turn references 
the .png file. 

 
 

 

17 

Open up the .png file. The .png file is a 
normal image file. As long as all three of 
these files stay in the same directory, 
you are good to go. 

 

18 

Open up a fresh new project in MeshLab 
and import the .obj you just made. 
 
If MeshLab crashes, you probably had 
spaces in the name of one of those three 
files. Rename as needed, but make sure 
you edit the references in each one to 
account for the changes. 
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19 
Congratulations, you’re done! The .obj 
should open up with only a single mesh 
and the texture already on it. 
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Supplemental Troubleshooting Guides 

The following guides go into more detail about potential issues and how to solve them. If your problems 

persist, please reach out to the community at: 

https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-3d-scanner 

Precisely Calibrating the Stepper Motor Driver 

Earlier in this document, we give a ballpark method for calibrating the 

Stepper Motor Driver. If your stepper motor is experiencing erratic behavior, 

we recommend calibrating the Stepper Motor Driver more precisely with 

the following method. 

Precisely adjusting the Stepper Motor Driver will require the following tools: 

 

   

Multimeter 
Small Phillips Head Screwdriver 

or Screwdriver Bit 
Alligator Clips 

 

 Plug in the Uno Clone to your computer via USB. This will power the board. You must use the USB, 

make sure you do not use the barrel plug. The CT Board must also remain unplugged. 

 Prepare your multimeter. Put a probe on the black side of the multimeter and an alligator clip on 

the red side. Adjust it so that it can read voltage between 0V and 1V to at least 0.01V accuracy. 

 Clamp the alligator clip to the Phillips head screwdriver. Ensure that there is a good electrical 

connection between the two. 

WARNING: From this point on, it can be easy to accidentally short out the 

Stepper Motor Driver and render it useless. Please be very aware of what 

the probes are touching and make sure they are not making contact with 

any pins or exposed solder on the board. 

 Measure the voltage between the Uno Clone’s ground and the screw. 

Place the black probe at any of the locations indicated in green boxes 

on the picture at right. These green highlighted areas are all 

connected to the Uno Clone’s ground. Place the screwdriver with 

SCREW 

HEAT SINK 

https://groups.google.com/a/cowtechengineering.com/forum/?hl=en#!forum/cowtech-ciclop-3d-scanner
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alligator clip attached on the small screw of the Stepper Motor Driver. The multimeter should be 

measuring a voltage somewhere between 0V and 1.2V 

 Twist the screw until the multimeter reads 0.48V. It’s ok to be a few hundredths of a volt off in 

either direction. 

 Unplug the Uno Clone.  

 Stick the heat sink to the Stepper Motor Driver. The heat sink has an adhesive backing protected 

by a layer of paper. Peel off the paper and stick the adhesive side of the heat sink to the black 

square in the center of the Stepper Motor Driver (known as the IC). The heat sink ensures that 

the driver does not overheat and burn out. Please make sure that the heat sink is not touching 

any exposed metal surfaces on the driver such as the pins to the left and right of it. 

 Congratulations, you’re done with calibrating the stepper! 
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Troubleshooting Camera Connection Problems 

The steps below are for the Windows OS. If you’re using a different OS or if the steps below do not help, 

visit either of the following resources for troubleshooting help: 

 BQ Ciclop Google Group - https://groups.google.com/forum/#!forum/ciclop-3d-scanner  

 Horus Github - https://github.com/bqlabs/horus  

Please remember that Horus is software created and maintained by BQ. While CowTech provides 

supplemental tips to help you get through potential issues with Horus, further troubleshooting and 

suggestions for improvement are best directed toward the BQ links above. 

If Horus can’t detect your Logitech C270 
Webcam, it may bring up an error window 
similar to the one shown at right. 

 

Usually Horus will bring up something similar to 
this menu after you hit “OK.” Some of the 
values here might look different for you, and 
some fields may be missing. 
 
 

 
 
A Note on USB 2.0 vs USB 3.0: Some users report 
that the camera will not work with a USB 3.0 
port. It may be helpful to try using a USB 2.0 
port on your computer. 
 
Blue colored ports are always USB 3.0 ports, 
while black colored ports are generally USB 2.0 
ports. To more accurately determine what kind 
of USB ports your computer has, it may be 
easiest to look up your computer model’s 
specifications or use a system information tool 
such as Speccy. 
 

 

USB 2.0 USB 3.0 

https://groups.google.com/forum/#!forum/ciclop-3d-scanner
https://github.com/bqlabs/horus
https://www.piriform.com/speccy
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Second thing to try: Quit out of Horus, unplug the camera, and plug the camera back in. Open up Horus 
and give it a shot. Sometimes this will resolve the issue. 
 

 
Third thing to try: Quit out of Horus. Plug in the 
camera. Click Windows Icon -> Control Panel -> 
Devices and Printers. Right click the icon 
labeled “Logitech HD Webcam C270.” 
 
If you don’t see the icon, the issue is not with 
Horus but with the Logitech drivers. Check the 
Logitech website to troubleshoot: 
http://support.logitech.com/en_us/product/h
d-webcam-c270  
  

Click Properties -> Hardware -> Properties -> 
Change Settings -> Driver -> Uninstall. There 
may be a box asking if you want to delete the 
driver files, make sure it is checked and then 
click ok. The picture at right shows this series 
of clicks graphically. 
 
Some users report that they must instead 
uninstall from Control Panel -> Device Manager. 
If this is the case, select the Logitech C270 
Webcam and uninstall it from the Device 
Manager instead. 

 
 
Now unplug the camera and plug it back in. Windows should begin automatically installing generic 
Windows webcam drivers. Once installation is complete, open up Horus and now the camera should be 
recognized when pressing the connect button. If not, try once again changing the values of “Camera 
ID” and “Serial Name” like you did earlier. 
 
 
Fourth thing to try: Close Horus and uninstall the generic Windows drivers from the previous step. The 
steps to uninstall them should be the same as before. Reinstall the official Logitech drivers. They can be 
found at the link below: 
http://support.logitech.com/en_us/product/hd-webcam-c270 
Installing the official Logitech drivers will require Windows to restart. 
 

 

 

 
(CHECK THE BOX) 

http://support.logitech.com/en_us/product/hd-webcam-c270
http://support.logitech.com/en_us/product/hd-webcam-c270
http://support.logitech.com/en_us/product/hd-webcam-c270
http://support.logitech.com/en_us/product/hd-webcam-c270
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Please reach out to us on the CowTech Google Group and the BQ links above if your issue persists. 

Occasionally, the camera connectivity error window can be caused by connectivity issues to the Uno 

Clone board. Please see the section titled “Troubleshooting Uno Clone Connection Problems” at the end 

of this document for tips on how to solve this.  

https://groups.google.com/forum/#!forum/cowtech-ciclop-3d-scanner
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Troubleshooting Laser Focus Problems 

Some users report that their lasers are unable to make thin, bright lines necessary for good scans. The 

following guide explains the origin of this issue and provides steps to fix it. 

 

1 

 
Make sure you have all the parts shown. 
Above is an exploded view of a laser. At 
right is a picture of the fully assembled 
laser. Note that the Beam Lens and Spring 
are not visible in a fully assembled laser. 

 

2 

Begin by removing the laser from your 
scanner and fully unscrewing the Focus 
Ring.  
 
Don’t worry if the Line Lens comes out 
when you do this, just make sure you don’t 
lose it. 

 

Focus Ring 

Line Lens Beam Lens Spring Optics Body Laser Body 

Laser Body 

Optics Body 

Focus Ring 
Line Lens 

UNSCREW ALONG 

THIS LINE 
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3 

Ensure that the Beam Lens is screwed all the way into the Focus Ring. See the picture below for an 
example of this. If you’ve been having laser focusing issues, usually this is because the Beam Lens is 
screwed too far into the Optics Body. This will reduce the possible range of focus for the laser. If 
this is the case, the Beam Lens will probably not unscrew out along with the Focus Ring. Instead it 
will stay inside the Optics Body. 
 
If the Beam Lens does not come out along with the Focus Ring, unscrew it from the Optics Body and 
snugly screw it into the Focus Ring. The Line Lens should fit between the Focus Ring and the Beam 
Lens. Ideally, the Beam Lens should not spin freely off the Focus Ring. A diagram of what your laser 
should now look like is below. 

 

 
 
 

- 

The Beam Lens must be oriented properly. On one end it has a convex opening. On the other end it 
has a smaller opening. Ensure that the large convex opening is facing in the direction that the laser 
points. Above are pictures of both orientations. 
 
The Line Lens does not need to be oriented one way or another. It has a smooth side and ridged 
side. Either side can face in either direction, its orientation will not affect your ability to focus the 
laser. 

4 

Screw the Focus Ring + Lens assembly into the 
Optics Body. Make sure that the spring sits 
between them. 
 
Your laser is now ready to go. You can focus it by 
twisting the Focus Ring. A good focus is a red 
line on the object 1mm or less in thickness. 
Remember that the laser’s focus is dependent 
on the distance between the laser and the 
surface it hits. You may need to readjust the 
focus when scanning objects of significantly 
varying size. 

 
 

Screw in nice 

and snug 

Optics Body + Laser Body 
Focus Ring + Line Lens + Beam Lens 

Spring 

Line Lens orientation should 

not be important, either the 

bumpy side or the smooth 

side can face outward 

Convex Opening Small Opening 
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Troubleshooting Uno Clone Connection Problems 

The following guide assumes that you’ve never worked with an Arduino / Arduino Clone microcontroller or 

the Arduino IDE. The steps below are for the Windows OS. If you’re using a different OS or if the steps 

below do not help, visit either of the following resources for troubleshooting help: 

 BQ Ciclop Google Group - https://groups.google.com/forum/#!forum/ciclop-3d-scanner 

 Horus Github - https://github.com/bqlabs/horus 

Please remember that Horus is software created and maintained by BQ. While CowTech provides 

supplemental tips to help you get through potential issues with Horus, further troubleshooting and 

suggestions for improvement are best directed toward the BQ links above. 

1 

If Horus cannot recognize the Uno Clone, it may give an error message saying so. Alternatively, 
Horus will sometimes give an error message related to the camera if it cannot detect the Uno 
Clone. 
 

2 Power the scanner. Plug in the Uno Clone and the camera via USB to your computer. 

3 

In Horus, go to Edit -> Preferences -> Upload 
firmware. Ensure that “Arduino Uno” is 
selected. 
 
Restart Horus and try to connect once again. 

 

4 

If the board is still not recognized, it may be 
useful to determine if Horus is properly 
uploading code to the Uno Clone. To test this, 
download the Arduino IDE here: 
https://www.arduino.cc/en/Main/Software 
 
The IDE is the place where you can load code 
from your computer onto your Uno Clone. 
Install the latest version of the IDE and open it. 
At right is a picture of what this might look like. 

 

https://groups.google.com/forum/#!forum/ciclop-3d-scanner
https://github.com/bqlabs/horus
https://www.arduino.cc/en/Main/Software
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5 

Delete the text that appears in the IDE window 
by default. Go to the following link and find the 
box of code that contains the “Blink” program: 
https://www.arduino.cc/en/Tutorial/Blink 
 
Copy and paste this code into the Arduino IDE. A 
screenshot of what this code looks like is 
presented at right. Blink is a common tool used 
to test and troubleshoot Arduinos. It simply 
flashes a small built-in LED on for one second 
and then off for one second. 

 

6 Go to Tools -> Board and select 
“Arduino/Geniuno Uno”. 

 

7 

Go to Tools -> Port and select one of the 
available options. It should read something like 
COMX, where X is a number. If the next step in 
this guide does not work, select a different port 
and retry. 

 

https://www.arduino.cc/en/Tutorial/Blink
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8 

Press the “Upload” button. Blink is now 
uploaded into your Uno Clone. You should see 
the small LED labeled “L” flashing on for one 
second and then off for another. 

 

9 

If you’re having issues uploading Blink, then your computer is having a USB driver or port problem. 
Please see the Arduino webpage to help troubleshoot further: 
https://www.arduino.cc/en/Guide/Troubleshooting 
 
As mentioned above, a common fix is to change your COM port. Please also ensure that you have 
the most recent version of the IDE and that you have properly installed the Uno Clone drivers 
provided on the CowTech website. 

10 

Close the Arduino IDE, unplug the Uno Clone, and start Horus. Plug the Uno Clone back in once 
Horus is open and try to connect. It should fail because the board has Blink loaded on it. Upload 
the firmware again the same way you did earlier in this section through Edit -> Preferences -> 
Upload Firmware. 

11 
If the “L” LED is still blinking after the previous step, then the issue is with Horus. Please post your 
issue to the BQ Horus google group here: 
https://groups.google.com/forum/#!forum/ciclop-3d-scanner 

 

“L” LED 

should be 

blinking. 

Upload Button 

https://www.arduino.cc/en/Guide/Troubleshooting
https://groups.google.com/forum/#!forum/ciclop-3d-scanner

